New MCP server — Bring vulnerability intelligence into your AI
Back to feed

CVE-2021-45617

NVDCIRCLENISA

EUVD-2021-32383 · Published Dec 26, 2021

Certain NETGEAR devices are affected by command injection by an unauthenticated attacker. This affects CBR40 before 2.5.0.24, EAX20 before 1.0.0.48, EAX80 before 1.0.1.64, EX7500 before 1.0.0.72, R6400 before 1.0.1.68, R6900P before 1.3.2.132, R7000 before 1.0.11.116, R7000P before 1.3.2.132, R7900 before 1.0.4.38, R7960P before 1.4.1.66, R8000 before 1.0.4.66, RAX200 before 1.0.3.106, RS400 before 1.5.1.80, XR300 before 1.0.3.68, MK62 before 1.0.6.110, MR60 before 1.0.6.110, R6400v2 before 1.0.4.106, R8000P before 1.4.1.66, RAX20 before 1.0.2.64, RAX45 before 1.0.2.82, RAX80 before 1.0.3.106, MS60 before 1.0.6.110, R6700v3 before 1.0.4.106, R7900P before 1.4.1.66, RAX15 before 1.0.2.64, RAX50 before 1.0.2.82, RAX75 before 1.0.3.106, RBR750 before 3.2.16.22, RBR850 before 3.2.16.22, RBS750 before 3.2.16.22, RBS850 before 3.2.16.22, RBK752 before 3.2.16.22, and RBK852 before 3.2.16.22.

Technologies

Netgear Rbr850Netgear Rax15 FirmwareNetgear R6900PNetgear Eax20 FirmwareNetgear Mk62 FirmwareNetgear Mk62Netgear R7000Netgear Rax80 FirmwareNetgear R7900 FirmwareNetgear Rbk852Netgear R6700V3 FirmwareNetgear R8000 FirmwareNetgear Rax45Netgear Rbk852 FirmwareNetgear Rax20Netgear Xr300 FirmwareNetgear Rbr850 FirmwareNetgear Rs400Netgear R8000Netgear Rax15Netgear Eax80 FirmwareNetgear R7000PNetgear Eax20Netgear Cbr40 FirmwareNetgear R7000P FirmwareNetgear R7000 FirmwareNetgear Mr60Netgear R6400 FirmwareNetgear R8000PNetgear Rbk752Netgear Ex7500Netgear Rs400 FirmwareNetgear R7900P FirmwareNetgear Rax75Netgear R6900P FirmwareNetgear Ex7500 FirmwareNetgear Rax200Netgear Rax20 FirmwareNetgear Ms60Netgear R6700V3Netgear Rax50 FirmwareNetgear Rbs850Netgear Rax75 FirmwareNetgear R7900PNetgear Rbs750 FirmwareNetgear Eax80Netgear Rbr750Netgear R7960P FirmwareNetgear Rbs750Netgear Rax80Netgear Rbr750 FirmwareNetgear Rax50Netgear Mr60 FirmwareNetgear Ms60 FirmwareNetgear Rax200 FirmwareNetgear Cbr40Netgear Rbs850 FirmwareNetgear Rbk752 FirmwareNetgear Rax45 FirmwareNetgear R6400V2 FirmwareNetgear R6400V2Netgear R7960PNetgear R8000P FirmwareNetgear Xr300Netgear R6400Netgear R7900

Weaknesses

CWE-77

CVSS scores

  • v3.19.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
  • v2.010.0AV:N/AC:L/Au:N/C:C/I:C/A:C

MITRE ATT&CK

Inferred

Where this vulnerability fits in an attack

Initial Access

References

Potentially impacted assets

See if this affects your attack surface

Latest trending attack

Criticalyesterday

Google Brotli decoder - Remote Code Execution via compressed requests (Exploitation Check)

This control is the second step of the Patrowl response to CVE-2026-111497 (Node2Shell). It complements the first control of 22 October 2026, which focused on the Node.js runtime, and does not replace it. Why a second control CVE-2026-111497 is an out-of-bounds write in the Google Brotli decoder, the library that decompresses Brotli ("br") data. It was first published as a Node.js vulnerability, because Node.js bundles this decoder. Later publications showed that the flaw is in the library itself. Every product that embeds an affected version of the decoder is concerned, whatever its language or vendor. A public proof of concept demonstrates code execution. Any server that decompresses request bodies sent with "Content-Encoding: br" exposes the decoder to unauthenticated attackers. Known cases include Express 5 and NestJS 11 on Node.js, Koa and Fastify setups, Bun, Envoy and Istio with request decompression enabled, and any application or reverse proxy that decodes Brotli request bodies with an affected library. The flaw also works in the other direction. A malicious server can compromise an unpatched client that decodes a Brotli response, for example Node.js fetch(), Python clients (requests, httpx, aiohttp, Scrapy) with the Brotli or brotlicffi package, or libcurl builds with Brotli support. What this control checks Patrowl sends small, valid Brotli-compressed requests to each asset and observes whether the server decodes them. The check does not depend on the technology: it detects the behaviour, whatever the stack behind it. These requests are what any legitimate client could send. They never reach the vulnerable code path and cannot affect the availability of the service. How to read the result Potentially impacted means the asset decodes Brotli request bodies: the attack surface is exposed. It does not confirm that the asset is vulnerable. The version of the Brotli decoder in use is not visible from the outside. This check covers applications that parse request bodies on their root path. A Not impacted result does not rule out exposure on other routes, nor on the client side. Checking the versions on the servers remains the only exhaustive verification. Affected and fixed versions Google Brotli 1.0.3 to 1.2.0 are affected, fixed in 1.0.10, 1.1.1 and 1.2.1. Fixed releases of the main products embedding it: Node.js 22.23.4, 24.22.1 and 26.12.1 (end-of-life lines 20.x and older and 25.x receive no fix), Bun 1.4.4, Envoy 1.37.8, 1.38.6, 1.39.3 and 1.40.0, Istio 1.29.9, 1.30.6 and 1.31.2, Python Brotli 1.2.1 and brotlicffi 1.2.1.0. Products that link against the system library depend on the Brotli package of the Linux distribution. Recommendations Update every component that embeds the Brotli decoder (only real fix). Start with the assets flagged by this control. Restart the processes after the update. Rebuild containers, single-executable applications and appliances that bundle an affected runtime or library. Reduce the exposure until the update is deployed. Reject requests with "Content-Encoding: br" at the reverse proxy, load balancer or WAF, case-insensitively and including lists such as "gzip, br". On Envoy and Istio, disable request decompression for Brotli. Review outbound calls. List the features that fetch content from servers you do not control, and patch the services that host them first.

Take 15 minutes to discover our platform with our experts

Patrowl Intel platform screenshot