New MCP server — Bring vulnerability intelligence into your AI
Back to feed

CVE-2023-27917

NVDCIRCLENISA

EUVD-2023-31643 · Published Apr 11, 2023

OS command injection vulnerability in CONPROSYS IoT Gateway products allows a remote authenticated attacker who can access Network Maintenance page to execute arbitrary OS commands with a root privilege. The affected products and versions are as follows: M2M Gateway with the firmware Ver.3.7.10 and earlier (CPS-MG341-ADSC1-111, CPS-MG341-ADSC1-931, CPS-MG341G-ADSC1-111, CPS-MG341G-ADSC1-930, and CPS-MG341G5-ADSC1-931), M2M Controller Integrated Type with firmware Ver.3.7.6 and earlier versions (CPS-MC341-ADSC1-111, CPS-MC341-ADSC1-931, CPS-MC341-ADSC2-111, CPS-MC341G-ADSC1-110, CPS-MC341Q-ADSC1-111, CPS-MC341-DS1-111, CPS-MC341-DS11-111, CPS-MC341-DS2-911, and CPS-MC341-A1-111), and M2M Controller Configurable Type with firmware Ver.3.8.8 and earlier versions (CPS-MCS341-DS1-111, CPS-MCS341-DS1-131, CPS-MCS341G-DS1-130, CPS-MCS341G5-DS1-130, and CPS-MCS341Q-DS1-131).

Technologies

Contec Cps-Mc341-Ds2-911 FirmwareContec Cps-Mcs341-Ds1-111 FirmwareContec Cps-Mg341-Adsc1-931Contec Cps-Mg341G-Adsc1-930Contec Cps-Mc341-A1-111Contec Cps-Mc341-Adsc1-111 FirmwareContec Cps-Mc341-Adsc2-111 FirmwareContec Cps-Mg341G-Adsc1-930 FirmwareContec Cps-Mg341-Adsc1-111 FirmwareContec Cps-Mg341-Adsc1-111Contec Cps-Mcs341G-Ds1-130 FirmwareContec Cps-Mcs341G5-Ds1-130Contec Cps-Mcs341-Ds1-111Contec Cps-Mc341G-Adsc1-110Contec Cps-Mc341-Ds11-111 FirmwareContec Cps-Mg341G5-Adsc1-931 FirmwareContec Cps-Mcs341Q-Ds1-131Contec Cps-Mc341-Ds11-111Contec Cps-Mc341-Adsc1-931 FirmwareContec Cps-Mc341-Adsc1-111Contec Cps-Mcs341Q-Ds1-131 FirmwareContec Cps-Mc341Q-Adsc1-111 FirmwareContec Cps-Mcs341-Ds1-131Contec Cps-Mc341G-Adsc1-110 FirmwareContec Cps-Mcs341-Ds1-131 FirmwareContec Cps-Mc341-Adsc1-931Contec Cps-Mg341G-Adsc1-111Contec Cps-Mc341-Ds2-911Contec Cps-Mc341-Ds1-111Contec Cps-Mc341Q-Adsc1-111Contec Cps-Mg341-Adsc1-931 FirmwareContec Cps-Mcs341G-Ds1-130Contec Cps-Mcs341G5-Ds1-130 FirmwareContec Cps-Mg341G-Adsc1-111 FirmwareContec Cps-Mg341G5-Adsc1-931Contec Cps-Mc341-A1-111 FirmwareContec Cps-Mc341-Ds1-111 FirmwareContec Cps-Mc341-Adsc2-111

Weaknesses

CWE-78

CVSS scores

  • v3.18.8CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

MITRE ATT&CK

Inferred

Where this vulnerability fits in an attack

Initial Access

References

Potentially impacted assets

See if this affects your attack surface

Latest trending attack

Criticalyesterday

Google Brotli decoder - Remote Code Execution via compressed requests (Exploitation Check)

This control is the second step of the Patrowl response to CVE-2026-111497 (Node2Shell). It complements the first control of 22 October 2026, which focused on the Node.js runtime, and does not replace it. Why a second control CVE-2026-111497 is an out-of-bounds write in the Google Brotli decoder, the library that decompresses Brotli ("br") data. It was first published as a Node.js vulnerability, because Node.js bundles this decoder. Later publications showed that the flaw is in the library itself. Every product that embeds an affected version of the decoder is concerned, whatever its language or vendor. A public proof of concept demonstrates code execution. Any server that decompresses request bodies sent with "Content-Encoding: br" exposes the decoder to unauthenticated attackers. Known cases include Express 5 and NestJS 11 on Node.js, Koa and Fastify setups, Bun, Envoy and Istio with request decompression enabled, and any application or reverse proxy that decodes Brotli request bodies with an affected library. The flaw also works in the other direction. A malicious server can compromise an unpatched client that decodes a Brotli response, for example Node.js fetch(), Python clients (requests, httpx, aiohttp, Scrapy) with the Brotli or brotlicffi package, or libcurl builds with Brotli support. What this control checks Patrowl sends small, valid Brotli-compressed requests to each asset and observes whether the server decodes them. The check does not depend on the technology: it detects the behaviour, whatever the stack behind it. These requests are what any legitimate client could send. They never reach the vulnerable code path and cannot affect the availability of the service. How to read the result Potentially impacted means the asset decodes Brotli request bodies: the attack surface is exposed. It does not confirm that the asset is vulnerable. The version of the Brotli decoder in use is not visible from the outside. This check covers applications that parse request bodies on their root path. A Not impacted result does not rule out exposure on other routes, nor on the client side. Checking the versions on the servers remains the only exhaustive verification. Affected and fixed versions Google Brotli 1.0.3 to 1.2.0 are affected, fixed in 1.0.10, 1.1.1 and 1.2.1. Fixed releases of the main products embedding it: Node.js 22.23.4, 24.22.1 and 26.12.1 (end-of-life lines 20.x and older and 25.x receive no fix), Bun 1.4.4, Envoy 1.37.8, 1.38.6, 1.39.3 and 1.40.0, Istio 1.29.9, 1.30.6 and 1.31.2, Python Brotli 1.2.1 and brotlicffi 1.2.1.0. Products that link against the system library depend on the Brotli package of the Linux distribution. Recommendations Update every component that embeds the Brotli decoder (only real fix). Start with the assets flagged by this control. Restart the processes after the update. Rebuild containers, single-executable applications and appliances that bundle an affected runtime or library. Reduce the exposure until the update is deployed. Reject requests with "Content-Encoding: br" at the reverse proxy, load balancer or WAF, case-insensitively and including lists such as "gzip, br". On Envoy and Istio, disable request decompression for Brotli. Review outbound calls. List the features that fetch content from servers you do not control, and patch the services that host them first.

Take 15 minutes to discover our platform with our experts

Patrowl Intel platform screenshot