New MCP server — Bring vulnerability intelligence into your AI
Back to feed

CVE-2025-13942

NVDCIRCLENISA

EUVD-2025-207551 · Published Feb 24, 2026

A command injection vulnerability in the UPnP function of the Zyxel EX3510-B0 firmware versions through 5.17(ABUP.15.1)C0 could allow a remote attacker to execute operating system (OS) commands on an affected device by sending specially crafted UPnP SOAP requests.

Technologies

Zyxel Lte3301-Plus FirmwareZyxel Ex7710-B0 FirmwareZyxel Nebula Nr7101Zyxel Dx4510-B1 FirmwareZyxel Vmg4927-B50A FirmwareZyxel Ex5512-T0 FirmwareZyxel Nr7101 FirmwareZyxel Vmg4927-B50AZyxel Nr7101Zyxel Lte3301-PlusZyxel Ex2210-T0Zyxel Ex2210-T0 FirmwareZyxel Ee6510-10 FirmwareZyxel Ee6510-10Zyxel Dx4510-B0Zyxel Wx5610-B0Zyxel Emg6726-B10A FirmwareZyxel Ex3510-B0 FirmwareZyxel Px3321-T1Zyxel Px5301-T0 FirmwareZyxel Nebula Lte3301-PlusZyxel Nebula Nr7101 FirmwareZyxel Dx4510-B1Zyxel Emg6726-B10AZyxel Ex5512-T0Zyxel Ex5510-B0 FirmwareZyxel Px5301-T0Zyxel Ex7710-B0Zyxel Ex3510-B1 FirmwareZyxel Wx5610-B0 FirmwareZyxel Ex5510-B0Zyxel Nebula Lte3301-Plus FirmwareZyxel Ex3510-B0Zyxel Px3321-T1 FirmwareZyxel Dx4510-B0 FirmwareZyxel Ex3510-B1

Weaknesses

CWE-78

CVSS scores

  • v3.19.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

MITRE ATT&CK

Inferred

Where this vulnerability fits in an attack

Initial Access

References

Potentially impacted assets

See if this affects your attack surface

Latest trending attack

Criticalyesterday

Google Brotli decoder - Remote Code Execution via compressed requests (Exploitation Check)

This control is the second step of the Patrowl response to CVE-2026-111497 (Node2Shell). It complements the first control of 22 October 2026, which focused on the Node.js runtime, and does not replace it. Why a second control CVE-2026-111497 is an out-of-bounds write in the Google Brotli decoder, the library that decompresses Brotli ("br") data. It was first published as a Node.js vulnerability, because Node.js bundles this decoder. Later publications showed that the flaw is in the library itself. Every product that embeds an affected version of the decoder is concerned, whatever its language or vendor. A public proof of concept demonstrates code execution. Any server that decompresses request bodies sent with "Content-Encoding: br" exposes the decoder to unauthenticated attackers. Known cases include Express 5 and NestJS 11 on Node.js, Koa and Fastify setups, Bun, Envoy and Istio with request decompression enabled, and any application or reverse proxy that decodes Brotli request bodies with an affected library. The flaw also works in the other direction. A malicious server can compromise an unpatched client that decodes a Brotli response, for example Node.js fetch(), Python clients (requests, httpx, aiohttp, Scrapy) with the Brotli or brotlicffi package, or libcurl builds with Brotli support. What this control checks Patrowl sends small, valid Brotli-compressed requests to each asset and observes whether the server decodes them. The check does not depend on the technology: it detects the behaviour, whatever the stack behind it. These requests are what any legitimate client could send. They never reach the vulnerable code path and cannot affect the availability of the service. How to read the result Potentially impacted means the asset decodes Brotli request bodies: the attack surface is exposed. It does not confirm that the asset is vulnerable. The version of the Brotli decoder in use is not visible from the outside. This check covers applications that parse request bodies on their root path. A Not impacted result does not rule out exposure on other routes, nor on the client side. Checking the versions on the servers remains the only exhaustive verification. Affected and fixed versions Google Brotli 1.0.3 to 1.2.0 are affected, fixed in 1.0.10, 1.1.1 and 1.2.1. Fixed releases of the main products embedding it: Node.js 22.23.4, 24.22.1 and 26.12.1 (end-of-life lines 20.x and older and 25.x receive no fix), Bun 1.4.4, Envoy 1.37.8, 1.38.6, 1.39.3 and 1.40.0, Istio 1.29.9, 1.30.6 and 1.31.2, Python Brotli 1.2.1 and brotlicffi 1.2.1.0. Products that link against the system library depend on the Brotli package of the Linux distribution. Recommendations Update every component that embeds the Brotli decoder (only real fix). Start with the assets flagged by this control. Restart the processes after the update. Rebuild containers, single-executable applications and appliances that bundle an affected runtime or library. Reduce the exposure until the update is deployed. Reject requests with "Content-Encoding: br" at the reverse proxy, load balancer or WAF, case-insensitively and including lists such as "gzip, br". On Envoy and Istio, disable request decompression for Brotli. Review outbound calls. List the features that fetch content from servers you do not control, and patch the services that host them first.

Take 15 minutes to discover our platform with our experts

Patrowl Intel platform screenshot