New MCP server — Bring vulnerability intelligence into your AI
Back to feed

CVE-2025-27421

NVDCIRCLENISA

EUVD-2025-5565 · Published Mar 3, 2025

Goroutine Leak in Abacus SSE Implementation

Goroutine Leak in Abacus SSE Implementation

Summary

A critical goroutine leak vulnerability has been identified in the Abacus server's Server-Sent Events (SSE) implementation. The issue occurs when clients disconnect from the /stream endpoint, as the server fails to properly clean up resources and terminate associated goroutines. This leads to resource exhaustion where the server continues running but eventually stops accepting new SSE connections while maintaining high memory usage. The vulnerability specifically involves improper channel cleanup in the event handling mechanism, causing goroutines to remain blocked indefinitely.

POC
Impact

This vulnerability affects all versions of Abacus prior to v1.4.0. The issue causes:

  • Permanent unresponsiveness of the /stream endpoint after prolonged use
  • Memory growth that stabilizes at a high level but prevents proper functionality
  • Selective denial of service affecting only SSE connections while other endpoints remain functional
  • Accumulated orphaned goroutines that cannot be garbage collected
  • High resource consumption under sustained client connection/disconnection patterns

Systems running Abacus in production with client applications that frequently establish and terminate SSE connections are most vulnerable. The issue becomes particularly apparent in high-traffic environments or during connection stress testing.

Patches

The vulnerability has been patched in Abacus v1.4.0. The fix includes:

  1. Implementing buffered channels to prevent blocking operations during cleanup
  2. Adding proper mutex-protected cleanup logic to ensure resources are released exactly once
  3. Implementing timeout protection for channel operations to prevent deadlocks
  4. Ensuring consistent cleanup when connections terminate unexpectedly
  5. Adding improved monitoring for client disconnections using request context
  6. Restructuring the event broadcasting system to safely handle client removal

Users should upgrade to v1.4.0 or later versions as soon as possible.

Workarounds

If upgrading is not immediately possible, the following workarounds can help mitigate the issue:

  1. Limit maximum connections: Configure your reverse proxy to limit the maximum number of concurrent connections to the /stream endpoints.

  2. Implement request timeouts: Configure your infrastructure to terminate long-lived SSE connections after a reasonable period.

  3. Restart regularly: Schedule regular restarts of the Abacus service to reclaim resources.

  4. Monitor memory usage: Set up alerts for abnormal memory growth patterns.

  5. Separate instance for SSE: Run a dedicated Abacus instance solely for handling SSE connections, allowing it to be restarted without affecting the main API functionality.

References
For More Information

Please contact the Abacus security team at abacus@jsn.cam for additional information or to report further security issues.

Technologies

Jasonlovesdoggo Abacus

Weaknesses

CWE-400CWE-772

CVSS scores

  • v3.17.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

MITRE ATT&CK

Inferred

Where this vulnerability fits in an attack

Initial Access Impact

References

Potentially impacted assets

See if this affects your attack surface

Latest trending attack

Criticalyesterday

Google Brotli decoder - Remote Code Execution via compressed requests (Exploitation Check)

This control is the second step of the Patrowl response to CVE-2026-111497 (Node2Shell). It complements the first control of 22 October 2026, which focused on the Node.js runtime, and does not replace it. Why a second control CVE-2026-111497 is an out-of-bounds write in the Google Brotli decoder, the library that decompresses Brotli ("br") data. It was first published as a Node.js vulnerability, because Node.js bundles this decoder. Later publications showed that the flaw is in the library itself. Every product that embeds an affected version of the decoder is concerned, whatever its language or vendor. A public proof of concept demonstrates code execution. Any server that decompresses request bodies sent with "Content-Encoding: br" exposes the decoder to unauthenticated attackers. Known cases include Express 5 and NestJS 11 on Node.js, Koa and Fastify setups, Bun, Envoy and Istio with request decompression enabled, and any application or reverse proxy that decodes Brotli request bodies with an affected library. The flaw also works in the other direction. A malicious server can compromise an unpatched client that decodes a Brotli response, for example Node.js fetch(), Python clients (requests, httpx, aiohttp, Scrapy) with the Brotli or brotlicffi package, or libcurl builds with Brotli support. What this control checks Patrowl sends small, valid Brotli-compressed requests to each asset and observes whether the server decodes them. The check does not depend on the technology: it detects the behaviour, whatever the stack behind it. These requests are what any legitimate client could send. They never reach the vulnerable code path and cannot affect the availability of the service. How to read the result Potentially impacted means the asset decodes Brotli request bodies: the attack surface is exposed. It does not confirm that the asset is vulnerable. The version of the Brotli decoder in use is not visible from the outside. This check covers applications that parse request bodies on their root path. A Not impacted result does not rule out exposure on other routes, nor on the client side. Checking the versions on the servers remains the only exhaustive verification. Affected and fixed versions Google Brotli 1.0.3 to 1.2.0 are affected, fixed in 1.0.10, 1.1.1 and 1.2.1. Fixed releases of the main products embedding it: Node.js 22.23.4, 24.22.1 and 26.12.1 (end-of-life lines 20.x and older and 25.x receive no fix), Bun 1.4.4, Envoy 1.37.8, 1.38.6, 1.39.3 and 1.40.0, Istio 1.29.9, 1.30.6 and 1.31.2, Python Brotli 1.2.1 and brotlicffi 1.2.1.0. Products that link against the system library depend on the Brotli package of the Linux distribution. Recommendations Update every component that embeds the Brotli decoder (only real fix). Start with the assets flagged by this control. Restart the processes after the update. Rebuild containers, single-executable applications and appliances that bundle an affected runtime or library. Reduce the exposure until the update is deployed. Reject requests with "Content-Encoding: br" at the reverse proxy, load balancer or WAF, case-insensitively and including lists such as "gzip, br". On Envoy and Istio, disable request decompression for Brotli. Review outbound calls. List the features that fetch content from servers you do not control, and patch the services that host them first.

Take 15 minutes to discover our platform with our experts

Patrowl Intel platform screenshot